Android 2.2 Market 依赖包

从2.1 到 Android 2.2(Froyo),变化是蛮大的,Android 2.1 安装market,需要装一大驼的东东:

/etc/permissions/com.google.android.datamessaging.xml
/etc/permissions/com.google.android.gtalkservice.xml
/system/framework/com.google.android.gtalkservice.jar
/system/app/EnhancedGoogleSearchProvider.apk
/system/app/GoogleCheckin.apk
/system/app/GoogleApps.apk
/system/app/gtalkservice.apk
/system/app/SetupWizard.apk
/system/app/Vending.apk
/system/app/TalkProvider.apk

到了 2.2 只用两个包就搞定:
/system/app/GoogleServicesFramework.apk
/system/app/Vending.apk

第一个,美其名曰:Google服务框架,整合了很多东西,2.1版本的Vending.apk login部分,也整合到了GoogleServicesFramework.apk,系统更新也在这包里。

具体的包,网上搜 Android 2.2的ROM,多的是。中间遇到了一个问题,就是无法建立帐号,在添加帐号,点公司/Goolge 这两项都无响应,开始怀疑是AccountAndSyncSettings.apk 这个包有问题。后面查出打开wifi后,kernel没有上报消息,状态栏没显示wifi的图标。

If you enjoyed this post, make sure you subscribe to my RSS feed!

3 thoughts on “Android 2.2 Market 依赖包

  1. Pingback: Android Market FAQ « 朴石

  2. wonderland

    看了你的文章大受启发,请问对于google的其他关联服务(gmail,map and so on^_^)依赖包有研究过吗,希望高手能分享更多经验

    Reply

Leave a Reply

Your email address will not be published. Required fields are marked *